Jamb con Asp.net y SqlDependecy

Sql Server 2005 y ASP.NET 3.5

El problema es conocido y está asociado con el rápido llenado de la secuela orlog con mensajes como

El cuadro de diálogo de notificación de consulta en el controlador de conversación '{F3EB22A6-CDB6-DF11-9BF1-003048CEA3F1}.' cerrado debido al siguiente error: & lt ;? xml version = "1.0"? & gt; -8490 Descripción Buscar en Google te lleva a dos sugerencias: hacer SqlDependecy. Cerrar solo en Application_End (como lo hago), esto reducirá el número de colisiones y enrollará un parche que salió después del tercer paquete de servicios que no encontré en el acceso gratuito.
¿Alguien ha tratado de resolver el problema tal vez más bellamente?